PHP 5.2 이하 버전에서 JSON 사용하기

오래전 만들어준 쇼핑몰에서 갑자기 제품 검색이 되지 않는 문제로 문의가 들어왔다.
이 쇼핑몰이 PHP단이나 JS단에서(많은 부분이 AJAX처리..) 이런저런 기능이 커스터마이징되서 많이 들어가 있었는데 그 중하나가 상품목록을 AJAX롤 보여주는 기능이었고 검색 후 목록이 나오지 않는 문제가 발행한것이었다..
작업을 위해 rsync로 본인의 작업서버로 가져오려 하려했지만 RSA값이 틀리다고 나오는것으로 서버가 바뀌었다는걸 직감했는데 아파치 PHP버전이 무려 4.4.9!!!! 왜 낮은 버전으로 내렸을까?..   이유는 모르겠고 아무튼 이리저리 확인해보니 JSON인코딩이 잘 안되는 문제였다. -솔루션에서 제공하는 함수로 해도 마찮가지-
이리저리 뒤져보고하다가 아래와 같은 코드로 해결했기에 소개한다.


함수의 원 출처는 불명..

저작자 표시 비영리 동일 조건 변경 허락
신고
크리에이티브 커먼즈 라이선스
Creative Commons License
Posted by TheBits

티스토리 툴바